Author Topic: Sound not playing on vsh_dr_pauseahead_v13  (Read 300 times)

Offline Durrbill

  • Member
  • *
  • Posts: 3
  • hiya
Sound not playing on vsh_dr_pauseahead_v13
« on: June 01, 2017, 04:24:51 pm »
Pretty much the title. Any of the songs that normally play don't.

I found that the cause of this is probably the way the map plays the music. It's based on soundscapes rather than ambient_generic entities, like most maps. I'm assuming that the reason it uses soundscapes is to have players hear separate songs, based on their location. I could fix this, but I'd make the songs the same for all players.

I'll notify you guys if I make any progress.

Offline VoiDeD

  • Full Admin
  • *****
  • Posts: 2,386
Re: Sound not playing on vsh_dr_pauseahead_v13
« Reply #1 on: June 01, 2017, 09:17:14 pm »
:thumbsup:

Since we had to rename the map, that nukes soundscripts/soundscapes. Let me know if you end up recompiling/fixing the pack lump for this.

Offline Durrbill

  • Member
  • *
  • Posts: 3
  • hiya
Re: Sound not playing on vsh_dr_pauseahead_v13
« Reply #2 on: June 23, 2017, 06:10:21 pm »
After doing some more digging, I found that we probably won't be able to get this fixed without messing up the textures/other materials the map uses. All of the source files located in the .bsp are compressed in a way (0x0e) that prevents them from being extracted. Including the sound and texture files. This means that if I recompiled the map after fixing the music problem, all textures in the map would be errors. So unless someone has a way other than GCFScape to extract .bsp files, or if someone has a dump of all the models/textures, I don't think this will have a fix.